Skip to content
Printer-friendly version

Minimum Web Browser Requirement


For optimum performance, the Web pages and Web-based applications hosted by the California Department of Education (CDE) require a current Web browser. It is the intent of CDE that all of its Web pages and Web-based applications will work well with Microsoft Internet Explorer 8.0 or higher and the current stable release and one previous release of Mozilla Firefox, Apple Safari, and Google Chrome.

Web browsers that are fully compatible with these browsers and older versions of these browsers may also be suitable, but CDE does not design, maintain, or test for browsers that are not listed above.

If you are not sure of the version of your browser, select Help in the menu bar of your browser and choose About.

Additional Information

Some Web pages and Web-based applications hosted by the CDE require the Web browser to support Javascript External link opens in new window or tab. and to accept session-based cookies External link opens in new window or tab.. By default, the major Web browsers are configured to handle these requirements.

Related Content
Questions:   Web Services Office | tsdweb@cde.ca.gov
Download Free Readers